WebCars! The Corvette Story

Sell - Buy a Corvette
1968 Corvette Up Close

Does Anybody Really Know What Time It Is?

Original Clock, not working Left: As the addage goes, "even a broken clock is accurate twice a day". That may be true but not very useful since you don't know when in the day it is correct.

Page 19 of the 1968 Corvette manual states "Your clock should be cleaned and oiled periodically" but there are no instructions as to how to perform the maintenance and "periodically" is not defined. Another question: did anyone actually do this?

Safari's clock, like the one on so many other classic cars (Corvette and otherwise) had stopped working. Replacing gauges is miserable work on most cars but in the case of the early C3 Corvettes, it's not so bad. The center instrument cluster comes out with the removal of seven screws. There is also a pair of studs with nuts that mechanically connect the instrument cluster to the center console but in many cases (including this one!) they've been previously removed and not reinstalled and therefore are not a problem.
1968 Chevrolet Corvette Clock Replacement 1968 Chevrolet Corvette Clock Replacement
Replacing the clock went as well as could be reasonably expected. Once access to the gauge console is obtained it's a simple matter of removing two bolts with a nut driver, disconnecting the one electrical terminal for the clock and removing the bulb / socket and installing the new clock as illustrated above. I then proceeded to open a brew and congratulate myself on a job well done.

Not so fast. Five days later I decided to treat myself and take Safari to work. Climbed in, turned the key and nothing. There was no voltage anywhere in the car; somehow the battery had completely discharged.

I put the charger on the battery to introduce some electrical life in the car. After an overnight charge, I put an ammeter in series with the battery and found that with every electrical item in the car completely off, the current draw was around three amps! That's a fair amount, about what a set of tail lights might require, so it was little wonder the battery had died. My first suspicion was that I had been sold a defective clock. Since it was one of the items on the car that still function even with the car sitting still and the key off (the others being the radio memory, alarm, interior lights) and it was new, it was suspect number one.

I pulled apart the instrument cluster and disconnected the new clock only to find the current draw was still @ three amps. The clock was not the problem.

Read the below thread on the ncrs.org forum to see what happened next:

May 6th, 2012, 05:33 PM #1 Paul Pollock (54300)

Subject: 1968 Current Drain Problem

All:

What would the expected current drain with the ignition switch off, doors closed, on a '68 convertible be?

Some background: I recently replaced the clock with an aftermarket unit. The new clock worked and the car started. About five days later I went to drive it to work and the (new) battery was completely dead. The clock wasn't even working as there was no voltage in the system.

After charging the battery I pulled the negative terminal and measured the current - approximately three amps!! That's way more than I would think it should be. I immediately suspected the new clock and removed it. But I still have around three amps of current draw, even with the ignition off and the doors closed.

I am now in trying to solve the problem by the ol' process of elimination. I have disconnected the factory alarm relay and the modern digital aftermarket radio (I do NOT trust those things!) along with the battery connection to the alternator. I also disconnected the gauges in the center console.

Does my '68 convertible have interior lights that go on when the doors are opened? Sorry for the dumb question but I don't recall seeing them and I am new to the car. It's too bright of a day now for me to give it a visual test. I know the center "glove box" compartment behind the seats has one but that one I can see but I can also witness a current difference of about .5 amps when I switch if off and on, so I know that isn't the problem. I can see the current increase to around 10 amps when I turn on the parking lights, so it is not like they are somehow accidentally on.

I do have a good DMM and an electronics background in my favor. I am considering pulling fuses one by one to see if the problem cab be further isolated.

As a matter of reference, my 1990 Mazda manual specified .020 amps of what they call "dark current". I had the chance to measure it and it was .005 amps.

Any ideas? I may start pulling fuses one by one to see if I can find the culprit, but am hoping to find a solution before resorting to that. I keep thinking that this problem only occurred after I replaced the clock, so I may have messed up something in the center instrument panel area. Before that I was able to go a week or two of inactivity and be able to start the car without a problem.

May 6th, 2012, 05:54 PM #2 Jim T_____
Re: 1968 Current Drain Problem
Paul I am long time owner of 1968 convertible, unplug the center "glove box " light. Mine has been disconnected for over thirty years. Next up is the windshield wiper switch. Start the car and turn on the windshield wipers, wet the windshield if you like, and let them do at least one swipe and using the windshield wiper switch turn off the windshield wipers. Now test for a current draw? Reason I mention the wiper switch is that if my wiper switch is " accidentally" turned on/off when the car is not running it will pull current until the car is started and the wiper switch is used to cycle the windshield wipers on/off. There is a inline plastic connection that is accessible from the jack storage area that I use to disable the glove box light from working.

May 6th, 2012, 07:47 PM #4 Paul Pollock (54300)
Infrequent User
Join Date    January 9th, 2012
Posts 5
Re: 1968 Current Drain Problem

Jim:

As my ~30 year old cubical neighbor at the day job might say: "YOU DA MAN!!!"

It was exactly as you described. Cycling the wiper motor brought it all under control.

Funny thing is, while I was working on the instrument console I noticed a bulb socket without a bulb. I didn't think much of it, figured it had been lost in the past or I had fumbled it loose. Since I had a spare I installed it. When it was all back together and I turned the key to the on position, a "WIPER O'RIDE" idiot light came on in the spot I had installed the bulb. I knew then that the problem was solved. Too bad the bulb hadn't been there all along, I could have saved myself some frustration.

Parasitic current is now around .030 amps, about what I would expect since it includes a modern digital radio (not my idea, no flames please) with it's memory requirements.

Thanks Jim for your prompt and excellent reply. Should you be in the Los Angeles area consider yourself do be due a beverage of your choice.

Now going for a celebration ride.

~paul

May 7th, 2012, 08:42 AM #5 Jim T_____
Extremely Frequent Poster

Re: 1968 Current Drain Problem

Paul good to hear that the wiper switch was the problem area. My 68's original glove box cover/lid is hard plastic (FEB built) and is not flat/straight enough any more to keep the glove box light off when the door is closed. This is why the switch was disconnected. Your convertible should have three interior lights, rotate your light switch counter-clock-wise and this action should illuminate a light in the cargo area near the drivers side spring/hinge that supports the deck lid. The other two lights are also exposed light bulbs in holders for the drivers and passengers foot well. The switches in the front of each door opening controls the illumination of interior lights when the light switch is not used for this illumination. Our 68 does not have the "Wiper O'Ride" light. If the wiper electrical switch mounted at the bottom of the steering column that stops the wipers over the windshield so the wipers can be cleaned or changed should always be in the off position unless it is being used for wiper maintenance in stopping the wiper action.

May 7th, 2012, 09:21 AM #6 Paul Pollock (54300)
Infrequent User

Re: 1968 Current Drain Problem

My '68 is a late July build. It still has the glove box light functional but I'll be aware that the switch can go awry. I now see the interior lights but they do not work, something I'll have to look into. In my case the wiper switch near the steering column is the only way I can get the wipers to function - the switch at the top of the center instrument cluster does not work. It's always something with cars of this nature, is that part of their charm?

Thanks again for your excellent help.

Regards,

Paul Pollock
WebCars! Webmaster
http://web-cars.com

/******************************************************************/

There is a moral to this story. Be proactive and join your local Corvette club. If you have (or even just appreciate) C3 and earlier Corvettes, then the NCRS (National Corvette Restorers Society) is highly recommended. Classic Corvettes may not be that difficult to own, but they do have their challenges. Organizations such as the NCRS can be an excellent resource for whatever issues that involve Corvette ownership. This is a classic example; only 21 minutes after my posting an excellent response was available. It doesn't get any better than that.


Note: Clicking on an image with this symbol (Boxes) will lead to a larger image.


Comments (4)

Topic: 1968 Corvette Up Close Electrical Frustrations
Sort
5/5 (1)
FacebookGoogle+Twitter
Gravatar
The Corvette Story says...
Yeah, the wiper motor drain can happen with a '68 Corvette. In my case I have a very late 1968 build. My understanding is that your early 1968 did not come with the warning light? As I constantly tell myself: "it is all part of their charm!"
14th June 2015 10:43pm
Gravatar
Mike Goforth says...
Have you made it to Bowling Green? This week we start making the 2016's
15th June 2015 4:09pm
Gravatar
The Corvette Story says...
Mike: No, we have not been to Bowling Green, it does have a high priority on our bucket list however. You work in the factory? Lucky guy, spending all day putting together C7s, am very jealous!!
15th June 2015 10:40pm
Gravatar
Full StarFull StarFull StarFull StarFull Star
Mike Goforth says...
I enjoyed reading about your 68. I also own a 68. I had a few of the same problems you had. I ran my battery down because of the wiper motor. I didn't realize when I did it the battery went completely dead over the winter. I had to replace my center gauge console. I sent my clock off to have it repaired. It runs but always fast. I have one of the very first C3's. The vin number makes it number 83.
14th June 2015 6:34pm
Page 1 of 1

Add Comment

* Required information
(never displayed)
 
Bold Italic Underline Strike Superscript Subscript Code PHP Quote Line Bullet Numeric Link Email Image Video
 
Smile Sad Huh Laugh Mad Tongue Crying Grin Wink Scared Cool Sleep Blush Unsure Shocked
 
1000
Captcha
Refresh
 
Enter code:
 
Notify me of new comments via email.
 
Remember my form inputs on this computer.
 
I have read and agree to the terms and conditions. *
 
 
Powered by Commentics

Corvette Spotter for the iPhone-txt
Introducing the Vette Spotter app for the iPhone.


The Vette Spotter app can identify the year of any Corvette.


All years and generations are covered, from 1953 to 2014. Over 350 photographs and detailed text are included.

Available_on_the_App_Store_Badge_US-UK_135x40_0801

To WebCars! Home